Problem ze zdjęciami .jpg - Wgrywanie nieudane

prostametoda

Avatar: prostametoda

2017-10-31 21:50

Spotkałem się z dziwnym problemem podczas wgrywania zdjęć. Na serwer nie można wgrać niektórych zdjęć z rozszerzeniem .jpg
Te same zdjęcia bezproblemowo wgrywają się po zmianie rozszerzenia na .jpeg

W general.php jest wszystko ok.
$config['allowed_extensions'] = 'pdf|swf|doc|docx|txt|xls|ppt|rtf|odt|ods|odp|rar|zip|7z|bz2|tar|gz|tgz|arj|jpg|jpeg|gif|png|mp3';

Czy ktoś wie może dlaczego tak się dzieje?

» Quick.Cart v6.x

Tomasz

marcin_k

Avatar: marcin_k

2017-11-02 18:39

Sproboj na innym serwerze czy dzieje sie to samo

prostametoda

Avatar: prostametoda

2017-11-08 21:29

Właśnie na innym serwerze nie ma tego problemu. Co może być przyczyną? Hosting u tego samego dostawcy, a na jednym jednak nie działa. Po zmianie rozszerzenia z .jpg na .jpeg jest wszystko OK.

Tomasz

Yaca

Avatar: Yaca

2017-11-09 11:29

A rozszerzenia masz jpg czy JPG?

Grzegorz

prostametoda

Avatar: prostametoda

2017-11-09 16:04

wszystkie małe litery, brak spacji itp.- jpg

Tomasz

jankesmj

Avatar: jankesmj

2019-06-13 11:05

Odświeżę temat. Quick.CMS w najnowszej wersji nie wgrywa plików, testowałem jpg, pdf, doc, zip, mp3. "Wgrywanie nieudane", na serwerze fizycznie brak tych plików. InfoPHP na hostingu OVH https://www.comitsystems.pl/test2/info.php, strona testowa https://www.comitsystems.pl/test2. Co dziwne stary quick.cms w wersji 4.2 działa i wgrywa pliki, strona: http://www.strefabram.pl InfoPHP: http://www.strefabram.pl/info.php

Roni

Avatar: Roni

2019-06-13 16:00

Te same zdjęcia i ten sam serwer?
Jeśli nie działają wszystkie czyli obrazki i dokumenty to prawdopodobnie coś nie tak jest z prawami dostępu do katalogów.
Sprawdź wymagania:
https://opensolution.org/docs/?p=pl-install
I spróbuj w międzyczasie też na innym serwerze (a swoją drogą napisz co to za dostawca serwera obecnie).

openzibi

Avatar: openzibi

2019-06-13 20:51

@jankesmj
Spróbuj wgrać zdjęcie o maksymalnym rozmiarze (wysokość lub szerokość) 900px.
W trakcie wgrywania odczekaj "3 sekundy" i dopiero wtedy zapisz zmiany.
Wspomniane "3 sekundy" to jest czas na wygenerowanie się miniaturek.
Jeżeli za wcześnie dasz "zapisz" to na wolnym serwerze duże zdjęcie powinno się wgrać ale nie wygenerują się miniaturki.

Zbyszek - StudioStrona.pl

jankesmj

Avatar: jankesmj

2019-06-25 08:52

Dziekuję za odpowiedzi.

@Roni
Dostawca to OVH. Od lat na nim mam skrypty quick.cms i quick.cart i do tej pory działały poprawnie. OVH twierdzi że spełnia wymagania skryptu. Prawa dostępu są prawidłowe. Na innym serwerze np. dhosting.pl wszystko działa poprawnie.

@openzibi
W trakcie przesyłania zdjęć na serwer już wytępuje ten komunikat, nie klikam od razu Zapisz.
Skrypt możecie przetestować https://www.comitsystems.pl/test2/admin login i hasło: sysadmin@sysadmin.com

jankesmj

Avatar: jankesmj

2019-07-10 14:30

i co? coś Wam się nasuwa jakieś rozwiązanie? :(

selekcjoner

Avatar: selekcjoner

2019-07-10 16:51

Dostajesz błąd 403 czyli nie masz dostępu do katalogów - tak to wygląda.

jankesmj

Avatar: jankesmj

2019-08-09 09:58

@selekcjoner, to jak to rozwiązać? Katalog /files/ zawsze miałem na 705, a próby 777 nie dają efektu. OVH nie widzi problemu i przyczyny błędu po ich stronie. -bezradny- :(

jankesmj

Avatar: jankesmj

2019-08-09 10:25

OVH odpisuje:

"W oparciu o informacje które Pan wskazał nie jesteśmy w stanie zidentyfikować
problemu. Jeżeli moduł z którego Pan korzysta nie ma opcji raportowania
błędów, sugerujemy kontakt z wydawcą modułu celem weryfikacji takiej
możliwości.
Dodam, że wszelkie potencjalne ograniczenia po stronie OVH mogą wynikać z
globalnych ustawień serwera Apache (obejmujących wszystkie usługi hostingowe).
Ustawienia te można sprawdzić na podstawie odpowiednich wartości zestawionych
dla poszczególnych wersji PHP pod poniższym adresem:
http://pro.ovh.net/infos/ "

pod tym linkiem są parametry serwera.

Ja mam ustawiony php na wersje 5.6 https://www.comitsystems.pl/info.php
Może trzeba coś przestawić w htaccess ?
Nie jestem biegły w tym temacie.

selekcjoner

Avatar: selekcjoner

2019-08-09 16:07

A strona https://www.comitsystems.pl działa prawidłowo ? Jest na tym samym serwerze..

jankesmj

Avatar: jankesmj

2019-08-14 08:30

Tak, comitsystems.pl to ten sam serwer. Wczesniej ta strona też działała prawidłowo. Jest to wersja 5.1. Bez żadnych modyfikacji skryptu nagle nie można wgrać zdjęć/plików przez upload w panelu. Również dotyczny to najnowszej wersji Quick.CMS. Dodatkowo strona noskowiacy.pl na werdji 5.1 też ma ten sam problem.

jankesmj

Avatar: jankesmj

2019-08-14 08:34

Dla informacji: strona w wersji 3.1 spnoskow.pl na hoście OVH ma inny starszy upload i tu ładowanie plików działa.

Do góry
o nas | kontakt