Error: no action was taken


Avatar: Qatan

2016-09-01 15:40

The website is made with Quick.CMS 5.5 EXT and it was working wonderfully until today after I made many modifications.
Now any change, anywhere in the Admin results in the error: "Error: no action was taken"
I must have done something wrong that is causing this error but I can't figure out what...
Any clue about what are the possible causes of this error?

Thank for any help

» Quick.Cms v5.x


Avatar: Qatan

2016-09-01 16:03

I tested with other browsers and all give the same result.

Only thing that works is backup... anything else gives that error.

Now I can't change anything on the website.

Please help...


Avatar: Qatan

2016-09-01 17:17

Found the problem!

It was the Cloudflare HTTPS option (see image:

Without that option it works

The problem is that without HTTPS activated I loose an important layer of protection. Any clue how to have Quick.CMS working with Cloudflare HTTPS?

I searched and found a Quick.CMS plugin: HTTPS
Installed it and for my surprise it didn't help anything... I really don't know for what is that plugin. It added a new field in PAGES called "HTTPS" and I activated it but doesn't seem to do anything... maybe I am wrong. Someone could explain it to me? For what is that plugin and how do you use it?

The solution was to simply disable HTTPS in CloudFlare (but I am not happy with it...)

Any idea?


Avatar: Qatan

2018-09-21 17:47

I found the solution!

For anyone on the same boat do the following:

Open core/commmon.php and change:

   if( isset( $_SERVER['HTTPS'] ) && $_SERVER['HTTPS'] === 'on' && !defined'HTTPS' ) )
define'HTTPS'true );


/* HAZAEL added the following to be able to use the Admin page from any connection http or https */
$isSecure false;
  if( isset( 
$_SERVER['HTTPS'] ) && $_SERVER['HTTPS'] === 'on' ) {               
$isSecure true;
  elseif (!empty(
$isSecure true;

  if( !
defined'HTTPS' ) && $isSecure ) {
define'HTTPS'true );
/* HAZAEL End*/


Avatar: Guido

2018-10-07 15:32


I'm maintaining a QuickCart 6.0 version shop and had the same problem when activating HTTPS.
In frontend it worked properly but in dashboard I wasn't able to save anything. Very frustrating.
My solution wasn't very safe: I disabled HTTPS for the backend.. so in frontend it looks ok..
So thanks for this fix!


Back to top
about us | contact