[en] Cannot save preferences


No avatar

2005-08-29 12:20

Hi All,

QC ver. 0.3.1/PHP5.0.3

I cannot save preferences from the admin panel (pl: Konfiguracja). Whenever I choose: Zapisz (Save) I get the following:

Warning: fopen(config/general.php) [function.fopen]: failed to open stream: Permission denied in /home/ksieg/core/preferences.php on line 131

followed by a bunch of lines with:

Warning: fwrite(): supplied argument is not a valid stream resource in /home/ksieg/core/preferences.php on line 147

I tried uploading the preferences.php file with required changes, it worked by it'snot the way ;-).

Something with access rights (it has 644) on the server? If it not the case what else can I do, please?




No avatar

2005-08-29 12:28

general.php need to be CHMOD 777! not 644


No avatar

2005-08-29 12:45

Thanks a lot for your reply!

I've chmoded the general.php to 777 and it worked the trick.
Funny thing is I originally chmoded 777 only the two directories as per instructions in the QC package and was able to save the prefs alright. Then I uploaded another test shop (a copy of the first) and after that I got the offending message.

Cheers again!


Back to top
about us | contact