Images not uploaded


No avatar

2006-05-11 18:17

I have this cart running on a Windows IIS 5 platform... with PHP 5.x running fine.

The only thing is when I try to add photos, it hangs till it times out, - BUT the wierd thing is that the photos are showing up and are uploaded almost immediately. It just hangs on RETURNING a response when I click save...

Any ideas?


Gert-Jan Jonker

No avatar

2006-06-10 09:34

First of all, the shop works great and looks good. Keep up the good work!

I do have a similar problem as decribed in this topic, it looks like the chmod is not 777 of some folders, but it is. Also it looks (for me) that all other things are ok as well (my server info is on

This problem occurs right from the start. I have tried gif, jpg and png images from exactly 100px wide and high. After looking into the forums I tried some of the mods (for instance Danielle's mod of FotoJobs.php), no one works.

My message when uploading a product photo is (a similar one for uploading the logo of the site):
Warning: move_uploaded_file(files/products/product.jpg): failed to open stream: Permission denied in /nfs/home/namastetherapie/html/ on line 166

Warning: move_uploaded_file(): Unable to move '/tmp/phpPUzOcC' to 'files/products/product.jpg' in /nfs/home/namastetherapie/html/ on line 166

Warning: getimagesize(): Read error! in /nfs/home/namastetherapie/html/ on line 178

Warning: copy(files/products/_m.jpg): failed to open stream: Permission denied in /nfs/home/namastetherapie/html/ on line 147

Warning: Cannot modify header information - headers already sent by (output started at /nfs/home/namastetherapie/html/ in /nfs/home/namastetherapie/html/ on line 48

Gert-Jan Jonker


No avatar

2006-06-25 23:36

I just wanted to give anyone who was having problems a heads-up: I downloaded the latest stable version (english) and wasn't seeing any product images. I noticed people in the first 2 pages of this thread talking about the /files/products/ folder, and noticed that it wasn't on my server or in my download. I created it, CHMODed it to 777, and everything's working fine now :)


No avatar

2006-11-02 23:27

I was having the mysterious "missing picture upload" and starting playing around with the image.

The max image size is NOT 2000 pixels in either direction, but in fact 1999 pixels.

Good luck.


No avatar

2006-11-03 02:26

This sure is a tricky problem. My pictures are loaded into the files/products - directory, but the thumbs aren't shown anywhere. Help anyone? Not in my case I guess.

Life without coding is pretending


No avatar

2006-11-03 15:34

I managed to load pictures to products finally, playing with pictures for hours. Problem is now this. From admin-sides setups I can get the pictures shown sizing the values by hand. Like this.

$config['products_photo_size'] = 500;
$config['categories_photo_size'] = 500;

$config['max_dimension_of_image'] = 900;

The problem is just, that I can not manage the picture sizes. If I add a product, which has a picture of course - I can't have a small thumb from the picture. If the picture is sized like 560x450px, it is shown in the first page in that size. If I drop the value from the adminpanel to 300px, that means the bug is on again. Nothing is uploaded and white blank space is all over. The products are uploaded to files/products though. I can see that using ws_ftp. So now I have kind of half-solution. I can upload images to products, but only small thumbs. that is the only way keep them small in the list. darn. ideas.?

Life without coding is pretending

wewior (OpenSolution)

Avatar: wewior

2006-11-03 20:43

maybe you have small memory limit on your server... if it works with smallest images it means that it work... try to ask your server admin for it...


No avatar

2006-11-04 01:15

But I can load there big pictures also. But they show up as huge pictures in the sidemenu. So there is no place I could manage, that it would show small picture in the sidemenu and in the products-area, and big picture in the products, when clicked the product's image to show the bigger picture.

It is a big thing to get those image shown in the cart, but still need some fixing..

Life without coding is pretending


Avatar: juanva22

2016-05-25 04:55

I read all the comments, and i tried all the solutions. It doesnt works.
This is my php info :

It works on wampp.
Please help



Avatar: Roni

2016-05-25 10:33

This topic is almost 1 years old.
So I think most of code in script changes.

Write something more: what error are you having (screenshot maybe), what script and version are you using etc
If it works on localhost (wampp) then it is definitely server settings - so quickest solution will be "change server provider" ;-)

Back to top
about us | contact